Averist 1.11

Operating systemsOS : Windows / Linux / Mac OS / BSD / Solaris
Program licensingScript Licensing : GPL - GNU Public License
CreatedCreated : Nov 6, 2007
Size downloadDownloads : 3
Program licensing
Thank you for voting...

Averist is a module that adds an authentication layer ...

averist by gna.org is a module that adds an authentication layer to any CGI application written in Perl.
It supports initial authentication through CGI (form), and it can use cgi (hidden form fields) or cookies for reauthentication after a configurable timeout. It can also use a DBM file, a flat file database, or an SQL database for storing session tickets for increased security.
The username and password check at the initial authentication can be done via a DBM file, an LDAP directory, a NIS database, the passwd database, a passwd-style file, or an SQL database. Averist 1.11 is written in perl for easy customization and expansion.
Demands:
• Perl 5. 004 (or later; tested with 5. 004, 5. 004_05, 5. 005, 5. 005_03, 5. 6. 0, 5. 6. 1, and 5. 8. 0)
• Digest::MD5 module (included with Perl 5. 8. 0 and later)
• Digest::SHA1 module
• Web server and Web browser supporting the Common Gateway Interface

Averist 1.11 scripting tags: perl, security, module, authentication, cgi, averist, file, authentication layer, database, system, authentication tool, security system. What is new in Averist 1.11 software script? - Unable to find Averist 1.11 news. What is improvements are expecting? Newly-made Averist 1.12 will be downloaded from here. You may download directly. Please write the reviews of the Averist. License limitations are unspecified.