CLISP 2.49

Operating systemsOS : Windows / Linux / Mac OS / BSD / Solaris
Program licensingScript Licensing : GPL - GNU General Public License
CreatedCreated : Oct 22, 2010
Size downloadDownloads : 1
Program licensing
Thank you for voting...

The Common Lisp language is a high-level, ...

The Common Lisp language is a high-level, general-purpose, object-oriented, dynamic, functional programming tool.
clisp by clisp.cons.org includes an interpreter, a compiler, a debugger, CLOS, MOP, a foreign language interface, i18n, POSIX and Perl regular expressions, a socket interface, fast bignums, arbitrary precision floats, and more. An X11 interface is available through CLX, Garnet and CLUE/CLIO. Command line editing is provided by readline. CLISP 2.49 runs Maxima, ACL2 and many other Common Lisp packages.
CLISP [clisp2.49.exe] runs on most GNU and Unix systems (GNU/Linux, GNU/Hurd, FreeBSD, NetBSD, OpenBSD, Solaris, Tru64, HP-UX, BeOS, NeXTstep, IRIX, AIX, Mac OS X and others) and on other systems (Windows NT/2000/XP/Vista, Windows 95/98/ME) and needs only 4 MB of RAM.
The user interface comes in English, German, French, Spanish, Dutch, Russian and Danish, and can be changed during run time.
News in the current CLISP - 0MB version:

• New command line option -disable-readline lets working around bugs and incompatibilities between readline CLISP 2.49 was built against and the library actually installed.

• FFI:OPEN-FOREIGN-LIBRARY now accepts the :REQUIRE argument.

• New user variable CUSTOM:*USER-LIB-DIRECTORY* is respected by REQUIRE and used by "clisp-link install".

• Dynamic module are now the default build option.

• Function RENAME-FILE now accepts :IF-EXISTS argument which determines the action when the destination exists, unless, of course, *ANSI* is T.

• The replacement value entered by the user in STORE-VALUE and USE-VALUE restarts is now EVALuated.

• The old user variable CUSTOM:*PRINT-CLOSURE* now controls interpreted closure output too (RFE#3001956).

• Module readline now supports readline 6. 1.

• Module pcre now supports pcre 8. 01.

• Module libsvm does not come with the upstream sources anymore, install locally and pass --with-libsvm-prefix to the top-level configure instead. All upstream versions up to 2. 91 are supported.

• Module berkeley-db now supports Berkeley-DB 4. 8.

• Module postgresql now supports PostgreSQL 8. 4.

• Module pari has been updated to support both 64 & 32 bit platforms with and without GMP.

• New functions OS:VERSION-COMPARE et al call strverscmp.

CLISP 2.49 scripting tags: clisp, lisp implementation, readline, ansi common, interface, supports, user, artificial intelligence, module. What is new in CLISP 2.49 software script? - Unable to find CLISP 2.49 news. What is improvements are expecting? Newly-made CLISP 2.50 will be downloaded from here. You may download directly. Please write the reviews of the CLISP. License limitations are unspecified.