Lockdown 6.x-1.0-beta1

Operating systemsOS : Windows / Linux / Mac OS / BSD / Solaris
Program licensingScript Licensing : GPL - GNU General Public License
CreatedCreated : Nov 26, 2010
Size downloadDownloads : 1
Program licensing
Thank you for voting...

A state machine for paranoia, with the halting state ...

A state machine for paranoia, with the halting state typically entailing the implementation of a scorched earth policy response (i. e. , erasing the drupal database). Think DEFCON for Drupal.
This module is meant primarily for "paranoid" Drupal use cases involving information warfare.
Typical users might be political dissidents in repressive regimes, BitTorrent bootleggers, various kinds of activists, and so on and so forth.
Basically, if you have adversaries trying to hunt & shut your site down or limit your ability to disseminate information, you'll probably want to install lockdown by Arto Bendiken to help maintain tight information discipline as well as to guard the perimeter and perhaps give you some advance warning when it's getting to be time to move shop.
The module integrates with the Messaging, Rules, Token, Secure Pages and IP Anonymize modules if they are installed.
Setup Process:
Unpack in your modules folder (usually '/sites/all/modules/')
Enable under Administer > Site Building > Modules
Most important functions of Lockdown 6.x-1.0-beta1:

• Lockdown [lockdown6.x-1.0-beta1.exe] level are a measure of the level of alertness and the general state of readiness to respond to threats posed by adversaries seeking to disrupt normal activities. Levels implement and enforce configurable Lockdown - 0MB policies and their activation can be triggered automatically through Rules events.

• Lockdown 6.x-1.0-beta1 policies are implemented as part of Lockdown 6.x-1.0-beta1 levels, and can be used to determine e. g. how accessible the Drupal site is to anonymous visitors (including web crawlers specifically) and what the data retention times are for access logs and other personally identifying information.

• Lockdown rules can be configured for each lockdown level and executed automatically when that level is activated, taking precautionary actions, such as notifying administrators, or defensive measures such as immediately scrubbing the database of any personally identifying information, executing pre-configured shell/SQL/PHP commands, or even erasing the Drupal database altogether.
Demands:

• Drupal 6. x

• PHP 5. 2 or higher

Lockdown 6.x-1.0-beta1 scripting tags: lockdown, shutdown access, level, deny, information, site lockdown, database, modules, deny access, drupal. What is new in Lockdown 6.x-1.0-beta1 software script? - Unable to find Lockdown 6.x-1.0-beta1 news. What is improvements are expecting? Newly-made Lockdown 6.1 will be downloaded from here. You may download directly. Please write the reviews of the Lockdown. License limitations are unspecified.