PHP-SecureArea 1.0

Operating systemsOS : Windows / Linux / Mac OS / BSD / Solaris
Program licensingScript Licensing : Commercial License ($65.00)
CreatedCreated : Jun 19, 2008
Size downloadDownloads : 15
Program licensing
Thank you for voting...

PHP-SecureArea allows authorized users to access a ...

php-securearea by withinweb.com allows authorized users to access a secure area of a web site after the purchase of a PayPal subscription.
Users are automatically allocated to the areas after payment has been confirmed from paypal or manually added through the admin displays.
PHP-secure 1.0 provides the checking of the completed transaction from PayPal, administration of users, and the sending of confirmation email and password to the customers.
The secure areas have parameters that include :
- the folder path of the protected area
- the cost to access the protected area
- the billing cycle for the subscription which may be from 1 day to many years.
When the user makes a valid purchase, they are able to log in to the secure area for the subscription period and continue to do so as long as the customer continues to pay the subscription. Access to the secure area will end when the customer cancels the subscription or when payment fails.
Subscription installments are also supported allowing a fixed number of payments to be made for a defined period.
The application does not have to be used with PayPal, as users can be manually created through the admin interface.
You can create as many secure areas as you like, with each area pointing to different folders or some pointing to the same folders but with differing costs and time limits. This allows you to have a cost for say 6 months access and a different cost for say 12 months access.
Main features
- Interacts with PayPal allowing customers to gain access to secure areas without any intervention from yourself.
- Customers can be added or removed using the admin interface independently of PayPal.
- Duration of user access defined in units of days, months or years.
- Automatic removal of users from the login_system after subscription period has expired.
- In built checks to ensure that PayPal payments are valid and to prevent spoofing.
- Written in PHP and requires mySQL.
- All credit card transactions are handled by PayPal.
Demands:
• PHP version PHP 4. 2. 0 or higher (including PHP5)
• Apache web server
• mySQL database version 3. 23 or higher
• Linux or FreeBSD operating system (not Windows)
• A Paypal Business or Premium account
• Email functionality on the web server so that the PHP scripts can send out emails to customers.

PHP-SecureArea 1.0 scripting tags: secure, php-securearea, website security system, login system, paypal, subscription, authentication script, access. What is new in PHP-SecureArea 1.0 software script? - Unable to find PHP-SecureArea 1.0 news. What is improvements are expecting? Newly-made PHP-SecureArea 1.1 will be downloaded from here. You may download directly. Please write the reviews of the PHP-SecureArea. License limitations are unspecified.